]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
c2b8aa3c652a628fcb6c03808159f8649042138b
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    YAML
7 %define pnam    Syck
8 Summary:        YAML::Syck - Fast, lightweight YAML loader and dumper
9 Name:           perl-YAML-Syck
10 Version:        0.64
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AU/AUDREYT/YAML-Syck-%{version}.tar.gz
16 # Source0-md5:  51054b5da582e381158f10276f82ae15
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-YAML >= 0.60
21 %endif
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module provides a Perl interface to the libsyck data
26 serialization library. It exports the Dump and Load functions for
27 converting Perl data structures to YAML strings, and the other way
28 around.
29
30 NOTE: If you are working with other language's YAML/Syck bindings
31 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
32 calling the Load/Dump functions. The default setting is for preserving
33 backward-compatibility with YAML.pm.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/Syck.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorarch}/YAML
61 %{perl_vendorarch}/YAML/*.pm
62 %dir %{perl_vendorarch}/JSON
63 %{perl_vendorarch}/JSON/Syck.pm
64 %dir %{perl_vendorarch}/YAML/Dumper
65 %{perl_vendorarch}/YAML/Dumper/Syck.pm
66 %dir %{perl_vendorarch}/YAML/Loader
67 %{perl_vendorarch}/YAML/Loader/Syck.pm
68 %dir %{perl_vendorarch}/auto/YAML
69 %dir %{perl_vendorarch}/auto/YAML/Syck
70 %{perl_vendorarch}/auto/YAML/Syck/*.bs
71 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/*.so
72 %{_mandir}/man3/*
This page took 0.067592 seconds and 2 git commands to generate.