]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
7ad0ea152d9d0fe28a33bdb2c397c50cb4a32eb9
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    YAML
7 %define         pnam    Syck
8 Summary:        YAML::Syck - fast, lightweight YAML loader and dumper
9 Summary(pl.UTF-8):      YAML::Syck - szybki, lekki moduł do wczytywania i zrzucania YAML-a
10 Name:           perl-YAML-Syck
11 Version:        1.20
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8f6d04ee5817b8479e1234264a8d458d
18 URL:            http://search.cpan.org/dist/YAML-Syck/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-YAML >= 0.60
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a Perl interface to the libsyck data
28 serialization library. It exports the Dump and Load functions for
29 converting Perl data structures to YAML strings, and the other way
30 around.
31
32 NOTE: If you are working with other language's YAML/Syck bindings
33 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
34 calling the Load/Dump functions. The default setting is for preserving
35 backward-compatibility with YAML.pm.
36
37 %description -l pl.UTF-8
38 Ten moduł udostępnia perlowy interfejs do biblioteki serializacji
39 danych libsyck. Eksportuje funkcje Dump i Load do przekształcania
40 perlowych struktur danych na łańcuchy YAML i z powrotem.
41
42 Uwaga: jeśli pracujemy z dowiązaniami YAML/Sych dla innego języka
43 (np. Ruby), należy ustawić $YAML::Syck::ImplicitTyping na 1 przed
44 wywołaniem funkcji Load/Dump. Domyślne ustawienie jest dla zachowania
45 wstecznej zgodności z YAML.pm.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make} \
54         CC="%{__cc}" \
55         OPTIMIZE="%{rpmcflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/Syck.pod
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %dir %{perl_vendorarch}/YAML
74 %{perl_vendorarch}/YAML/*.pm
75 %dir %{perl_vendorarch}/JSON
76 %{perl_vendorarch}/JSON/Syck.pm
77 %dir %{perl_vendorarch}/YAML/Dumper
78 %{perl_vendorarch}/YAML/Dumper/Syck.pm
79 %dir %{perl_vendorarch}/YAML/Loader
80 %{perl_vendorarch}/YAML/Loader/Syck.pm
81 %dir %{perl_vendorarch}/auto/YAML
82 %dir %{perl_vendorarch}/auto/YAML/Syck
83 %{perl_vendorarch}/auto/YAML/Syck/*.bs
84 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/*.so
85 %{_mandir}/man3/*
This page took 0.081737 seconds and 2 git commands to generate.