]> git.pld-linux.org Git - packages/perl-YAML-Syck.git/blob - perl-YAML-Syck.spec
rebuild with perl 5.32
[packages/perl-YAML-Syck.git] / perl-YAML-Syck.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    YAML
6 %define         pnam    Syck
7 Summary:        YAML::Syck - fast, lightweight YAML loader and dumper
8 Summary(pl.UTF-8):      YAML::Syck - szybki, lekki moduł do wczytywania i zrzucania YAML-a
9 Name:           perl-YAML-Syck
10 Version:        1.31
11 Release:        4
12 License:        MIT
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2394bccf64c01cdc796cd5227bba237f
16 URL:            http://search.cpan.org/dist/YAML-Syck/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a Perl interface to the libsyck data
24 serialization library. It exports the Dump and Load functions for
25 converting Perl data structures to YAML strings, and the other way
26 around.
27
28 NOTE: If you are working with other language's YAML/Syck bindings
29 (such as Ruby), please set $YAML::Syck::ImplicitTyping to 1 before
30 calling the Load/Dump functions. The default setting is for preserving
31 backward-compatibility with YAML.pm.
32
33 %description -l pl.UTF-8
34 Ten moduł udostępnia perlowy interfejs do biblioteki serializacji
35 danych libsyck. Eksportuje funkcje Dump i Load do przekształcania
36 perlowych struktur danych na łańcuchy YAML i z powrotem.
37
38 Uwaga: jeśli pracujemy z dowiązaniami YAML/Sych dla innego języka
39 (np. Ruby), należy ustawić $YAML::Syck::ImplicitTyping na 1 przed
40 wywołaniem funkcji Load/Dump. Domyślne ustawienie jest dla zachowania
41 wstecznej zgodności z YAML.pm.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc COMPATIBILITY Changes
67 %{perl_vendorarch}/YAML/Syck.pm
68 %{perl_vendorarch}/JSON/Syck.pm
69 %dir %{perl_vendorarch}/YAML/Dumper
70 %{perl_vendorarch}/YAML/Dumper/Syck.pm
71 %dir %{perl_vendorarch}/YAML/Loader
72 %{perl_vendorarch}/YAML/Loader/Syck.pm
73 %dir %{perl_vendorarch}/auto/YAML/Syck
74 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/Syck/Syck.so
75 %{_mandir}/man3/JSON::Syck.3pm*
76 %{_mandir}/man3/YAML::Syck.3pm*
This page took 0.051493 seconds and 3 git commands to generate.