]> git.pld-linux.org Git - packages/perl-XML-XSLT.git/blob - perl-XML-XSLT.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-XSLT.git] / perl-XML-XSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 %bcond_without  autodeps        # do not BR packages, needed only
5                                 # for resolving deps
6 #
7 %define         pdir    XML
8 %define         pnam    XSLT
9 Summary:        Perl XML::XSLT module
10 Summary(es.UTF-8):      Modulo Perl XML::XSLT
11 Summary(pl.UTF-8):      Moduł Perla XML::XSLT
12 Summary(pt_BR.UTF-8):   Modulo Perl XML::XSLT
13 Name:           perl-XML-XSLT
14 Version:        0.48
15 Release:        2
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  44d6d9e183d5c49c5d422ae42e7a9f68
21 URL:            http://search.cpan.org/dist/XML-XSLT/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov
24 %if %{with tests}
25 BuildRequires:  perl(Test::More) >= 0.33
26 %endif
27 %if %{with tests} || %{with autodeps}
28 BuildRequires:  perl-URI
29 BuildRequires:  perl-XML-DOM >= 1.25
30 BuildRequires:  perl-XML-Parser >= 2.23
31 BuildRequires:  perl-libwww
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Perl Interface to XSL Transformational sheets.
38
39 %description -l es.UTF-8
40 Perl Interface to XSL Transformational sheets.
41
42 %description -l pl.UTF-8
43 Moduły perla do arkuszy konwersji XSL.
44
45 %description -l pt_BR.UTF-8
46 Perl Interface to XSL Transformational sheets.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests: %{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README* Change* MANIFEST example*
72 %attr(755,root,root) %{_bindir}/*
73 %{perl_vendorlib}/XML/*
74 %{_mandir}/man[13]/*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.075881 seconds and 4 git commands to generate.