]> git.pld-linux.org Git - packages/perl-XML-Twig.git/blob - perl-XML-Twig.spec
- updated URL and macros
[packages/perl-XML-Twig.git] / perl-XML-Twig.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    Twig
7 Summary:        XML::Twig - a perl module for processing huge XML documents in tree mode
8 Summary(pl.UTF-8):      XML::Twig - przetwarzanie dużych dokumentów XML w trybie drzewa
9 Name:           perl-XML-Twig
10 Version:        3.52
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  14fbaf5ea8729b797ada51a880b6720e
16 URL:            https://metacpan.org/dist/XML-Twig
17 %if %{with tests}
18 BuildRequires:  perl-Encode >= 2.42_01
19 BuildRequires:  perl-IO-CaptureOutput >= 1.1102
20 BuildRequires:  perl-IO-stringy >= 2.110
21 BuildRequires:  perl-Scalar-List-Utils >= 1.23
22 BuildRequires:  perl-Test >= 1.25_02
23 BuildRequires:  perl-Test-Pod >= 1.45
24 BuildRequires:  perl-Tie-IxHash >= 1.22
25 BuildRequires:  perl-Unicode-Map8
26 BuildRequires:  perl-Unicode-String
27 BuildRequires:  perl-XML-Filter-BufferText >= 1.01
28 BuildRequires:  perl-XML-Handler-YAWriter >= 0.23
29 BuildRequires:  perl-XML-Parser >= 2.23
30 BuildRequires:  perl-XML-SAX-Writer >= 0.53
31 BuildRequires:  perl-XML-Simple >= 2.18
32 BuildRequires:  perl-XML-XPathEngine
33 %endif
34 BuildRequires:  perl-devel >= 1:5.8.0
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 BuildRequires:  rpmbuild(macros) >= 1.745
37 Requires:       perl-XML-Parser >= 2.23
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreq_perl XML::Twig::Elt
42
43 %description
44 This module provides a way to process XML documents. It is build on
45 top of XML::Parser.
46
47 The module offers a tree interface to the document, while allowing you
48 to output the parts of it that have been completely processed.
49
50 %description -l pl.UTF-8
51 Ten moduł udostępnia sposób na przetwarzanie dokumentów XML. Jest
52 zbudowany w oparciu o XML::Parser.
53
54 Moduł oferuje drzewiasty interfejs do dokumentu, pozwalając
55 przekazywać na wyjście części, które zostały już całkowicie
56 przetworzone.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL -y \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_bindir}/xml_*
80 %{perl_vendorlib}/XML/Twig.pm
81 %dir %{perl_vendorlib}/XML/Twig
82 %{perl_vendorlib}/XML/Twig/*.pm
83 %{_mandir}/man1/xml_*.1p*
84 %{_mandir}/man3/XML::Twig*.3pm*
This page took 0.089232 seconds and 4 git commands to generate.