]> git.pld-linux.org Git - packages/perl-XML-Smart.git/blob - perl-XML-Smart.spec
- updated to 1.6.9
[packages/perl-XML-Smart.git] / perl-XML-Smart.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    Smart
8 Summary:        XML::Smart - a smart, easy and powerful way to access/create XML files/data
9 Summary(pl):    XML::Smart - zgrabny, ³atwy i potê¿ny sposób dostêpu i tworzenia plików/danych XML
10 Name:           perl-XML-Smart
11 Version:        1.6.9
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  648309c0d613ddaca6f6b16e9f13c81d
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-Object-MultiType >= 0.03
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module has an easy way to access/create XML data. It's based on
26 the HASH tree that is made of the XML data, and enable a dynamic
27 access to it with the Perl syntax for Hash and Array, without needing
28 to care if you have a Hash or an Array in the tree. In other words,
29 each point in the tree work as a Hash and an Array at the same time!
30
31 You also have extra resources, like a search for nodes by attribute,
32 selection of an attribute value in each multiple node, change the
33 returned format, etc...
34
35 %description -l pl
36 Ten modu³ ma ³atwy sposób na dostêp i tworzenie danych XML. Jest
37 oparty na drzewie haszy tworzonym z danych XML i umo¿liwia dynamiczny
38 dostêp do nich z u¿yciem perlowej sk³adni dla haszy i tablic, bez
39 potrzeby pilnowania, czy w danym drzewie znajduj± siê hasze czy
40 tablice. Innymi s³owy, ka¿dy wêze³ w drzewie funkcjonuje jako hasz i
41 tablica jednocze¶nie!
42
43 Modu³ udostêpnia tak¿e dodatki takie jak poszukiwanie wêz³ów wed³ug
44 atrybutów, wybór warto¶ci atrybutu w ka¿dym wê¼le wielokrotnym, zmiana
45 formatu zwracanych danych itp.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:echo n | %{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 # get rid of pod documentation
64 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/XML/Smart/*.{pod,epod}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/XML/Smart.pm
73 %{perl_vendorlib}/XML/Smart
74 %{_mandir}/man3/*
This page took 0.088288 seconds and 3 git commands to generate.