]> git.pld-linux.org Git - packages/perl-XML-SimpleObject.git/blob - perl-XML-SimpleObject.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-SimpleObject.git] / perl-XML-SimpleObject.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    SimpleObject
7 Summary:        XML::SimpleObject perl module
8 Summary(pl.UTF-8):      Moduł perla XML::SimpleObject
9 Name:           perl-XML-SimpleObject
10 Version:        0.53
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/XML-SimpleObject-%{version}.tar.gz
16 # Source0-md5:  7826c2f27c36b90bfe731e0001da1021
17 URL:            http://search.cpan.org/dist/XML-SimpleObject/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-XML-LibXML >= 1.30
22 BuildRequires:  perl-XML-Parser
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 XML::SimpleObject is a small and simple package that takes the output
29 of XML::Parser as a tree, and gives simple methods for accessing the
30 structure of an XML document. It is very lightweight, but provides the
31 simplest access to an XML document possible. It does not subclass
32 XML::Parser; rather, it is meant to serve purely as an object struct
33 for an outgoing tree.
34
35 %description -l pl.UTF-8
36 XML::SimpleObject jest małym i prostym pakietem, który przyjmuje
37 wyjście z XML::Parser jako drzewo i pozwala na łatwy dostęp do
38 struktury dokumentu XML. Jest bardzo lekki, ale daje najprostszy
39 możliwy dostęp do dokumentów XML. Nie jest to podklasa XML::Parser -
40 natomiast ma służyć za obiektową strukturę dla wychodzącego drzewa.
41
42 %prep
43 %setup -q -n XML-SimpleObject%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README Changes
64 %{perl_vendorlib}/XML/SimpleObject.pm
65 %{perl_vendorlib}/XML/SimpleObject
66 %{perl_vendorlib}/XML/ex.pl
67 %{_mandir}/man3/*
This page took 0.109204 seconds and 4 git commands to generate.