]> git.pld-linux.org Git - packages/perl-XML-SAX-ExpatXS.git/blob - perl-XML-SAX-ExpatXS.spec
- up to 1.20 rel 0.1, builds here
[packages/perl-XML-SAX-ExpatXS.git] / perl-XML-SAX-ExpatXS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    SAX-ExpatXS
8 Summary:        XML::SAX::ExpatXS - Perl SAX 2 XS extension to Expat parser
9 Summary(pl):    XML::SAX::ExpatXS - rozszerzenie XS Perla SAX 2 do analizatora Expat
10 Name:           perl-XML-SAX-ExpatXS
11 Version:        1.20
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  fb6592f799316c588202f54a845ebbff
18 BuildRequires:  expat-devel
19 %if %{with tests}
20 BuildRequires:  perl-XML-SAX >= 0.12
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 XML::SAX::ExpatXS is a direct XS extension to Expat XML parser. It
28 implements Perl SAX 2.1 interface.
29
30 %description -l pl
31 XML::SAX::ExpatXS to bezpo¶rednie rozszerzenie XS do analizatora XML-a
32 Expat. Implementuje interfejs Perla SAX 2.1.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 # we want to add_parser in post, not on make install
38 head -n 98 Makefile.PL > Makefile.PL.tmp
39 mv -f Makefile.PL.tmp Makefile.PL
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 umask 022
59 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::ExpatXS))->save_parsers()"
60
61 %postun
62 if [ "$1" = "0" ]; then
63         umask 022
64         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::ExpatXS))->save_parsers()"
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %{perl_vendorarch}/XML/SAX/*
71 %dir %{perl_vendorarch}/auto/XML/SAX/ExpatXS
72 %attr(755,root,root) %{perl_vendorarch}/auto/XML/SAX/ExpatXS/*.so
73 %{perl_vendorarch}/auto/XML/SAX/ExpatXS/*.bs
74 %{_mandir}/man3/*
This page took 0.055749 seconds and 4 git commands to generate.