]> git.pld-linux.org Git - packages/perl-XML-SAX-ExpatXS.git/blob - perl-XML-SAX-ExpatXS.spec
- rebuild with perl 5.26
[packages/perl-XML-SAX-ExpatXS.git] / perl-XML-SAX-ExpatXS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    SAX-ExpatXS
8 Summary:        XML::SAX::ExpatXS - Perl SAX 2 XS extension to Expat parser
9 Summary(pl.UTF-8):      XML::SAX::ExpatXS - rozszerzenie XS Perla SAX 2 do analizatora Expat
10 Name:           perl-XML-SAX-ExpatXS
11 Version:        1.32
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f895b4be6b1b5f81366955cdd7ac5724
18 Patch0:         %{name}-Makefile.PL.patch
19 URL:            http://search.cpan.org/dist/XML-SAX-ExpatXS/
20 BuildRequires:  expat-devel
21 %if %{with tests}
22 BuildRequires:  perl-XML-SAX >= 0.13
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 XML::SAX::ExpatXS is a direct XS extension to Expat XML parser. It
30 implements Perl SAX 2.1 interface.
31
32 %description -l pl.UTF-8
33 XML::SAX::ExpatXS to bezpoĹ›rednie rozszerzenie XS do analizatora XML-a
34 Expat. Implementuje interfejs Perla SAX 2.1.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 umask 022
61 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::ExpatXS))->save_parsers()"
62
63 %postun
64 if [ "$1" = "0" ]; then
65         umask 022
66         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::ExpatXS))->save_parsers()"
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorarch}/XML/SAX/*
73 %dir %{perl_vendorarch}/XML/SAX
74 %dir %{perl_vendorarch}/auto/XML/SAX
75 %dir %{perl_vendorarch}/auto/XML/SAX/ExpatXS
76 %attr(755,root,root) %{perl_vendorarch}/auto/XML/SAX/ExpatXS/*.so
77 %{_mandir}/man3/*
This page took 0.254083 seconds and 4 git commands to generate.