]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 7 Jan 2004 15:48:26 +0000 (15:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-XML-SAX-Expat.spec -> 1.1

perl-XML-SAX-Expat.spec [new file with mode: 0644]

diff --git a/perl-XML-SAX-Expat.spec b/perl-XML-SAX-Expat.spec
new file mode 100644 (file)
index 0000000..291478b
--- /dev/null
@@ -0,0 +1,73 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    XML
+%define        pnam    SAX-Expat
+Summary:       XML::SAX::Expat - SAX2 Driver for Expat (XML::Parser)
+Summary(pl):   XML::SAX::Expat - sterownik SAX2 dla modu³u Expat (XML::Parser)
+Name:          perl-XML-SAX-Expat
+Version:       0.37
+Release:       1
+# same as perl
+License:       GPL or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: c48024d363a1ff9abaf8f9af592d38cd
+BuildRequires: perl-XML-NamespaceSupport >= 0.03
+BuildRequires: perl-XML-Parser >= 2.27
+BuildRequires: perl-XML-SAX >= 0.03
+BuildRequires: perl(XML::SAX::Base) >= 1.00
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This is an implementation of a SAX2 driver sitting on top of Expat
+(XML::Parser).
+
+%description -l pl
+To jest implementacja sterownika SAX2 w oparciu o modu³ Expat
+(XML::Parser).
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+# we want to add_parser in post, not on make install
+head -n 16 Makefile.PL > Makefile.PL.tmp
+mv -f Makefile.PL.tmp Makefile.PL
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+umask 022
+%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
+
+%postun
+if [ "$1" = "0" ]; then
+       umask 022
+       %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/XML/SAX/Expat.pm
+%{_mandir}/man3/*
This page took 0.041503 seconds and 4 git commands to generate.