]> git.pld-linux.org Git - packages/perl-XML-LibXSLT.git/blob - perl-XML-LibXSLT.spec
d81552edc719356f590c10e7afce260a149bd6ae
[packages/perl-XML-LibXSLT.git] / perl-XML-LibXSLT.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (fails in 1.53)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    LibXSLT
8 Summary:        XML::LibXSLT - interface to the GNOME libxslt library
9 Summary(pl):    XML::LibXSLT - interfejs do biblioteki libxslt z GNOME
10 Name:           perl-%{pdir}-%{pnam}
11 Version:        1.57
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9b831bc5a97444103f345105f0f6fced
17 BuildRequires:  libxslt-devel >= 1.0.6
18 BuildRequires:  perl-XML-LibXML >= 1.57
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       libxslt >= 1.0.6
22 Requires:       perl-XML-LibXML >= 1.57
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module is an interface to the gnome project's libxslt. This is an
27 extremely good XSLT engine, highly compliant and also very fast. I
28 have tests showing this to be more than twice as fast as Sablotron.
29
30 %description -l pl
31 Ten modu³ jest interfejsem do libxslt z projektu GNOME. Jest to bardzo
32 dobry silnik XSLT, o du¿ej zgodno¶ci ze standardem, a tak¿e bardzo
33 szybki. Wed³ug testów jest ponad dwa razy szybszy od Sablotrona.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/XML/LibXSLT.pm
62 %{perl_vendorarch}/XML/benchmark.pl
63 %dir %{perl_vendorarch}/auto/XML/LibXSLT
64 %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.bs
65 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.so
66 %{_mandir}/man3/*
67 %{_examplesdir}/%{name}-%{version}
This page took 0.125498 seconds and 2 git commands to generate.