]> git.pld-linux.org Git - packages/perl-XML-LibXSLT.git/blob - perl-XML-LibXSLT.spec
- s/gnome/GNOME/
[packages/perl-XML-LibXSLT.git] / perl-XML-LibXSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    LibXSLT
8 Summary:        XML::LibXSLT - interface to the GNOME libxslt library
9 Summary(pl):    XML::LibXSLT - interfejs do biblioteki libxslt z GNOME
10 Name:           perl-XML-LibXSLT
11 Version:        1.57
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9b831bc5a97444103f345105f0f6fced
18 BuildRequires:  libxslt-devel >= 1.0.6
19 BuildRequires:  perl-XML-LibXML >= 1.57
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       libxslt >= 1.0.6
23 Requires:       perl-XML-LibXML >= 1.57
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is an interface to the GNOME project's libxslt. This is an
28 extremely good XSLT engine, highly compliant and also very fast. I
29 have tests showing this to be more than twice as fast as Sablotron.
30
31 %description -l pl
32 Ten modu³ jest interfejsem do libxslt z projektu GNOME. Jest to bardzo
33 dobry silnik XSLT, o du¿ej zgodno¶ci ze standardem, a tak¿e bardzo
34 szybki. Wed³ug testów jest ponad dwa razy szybszy od Sablotrona.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/XML/LibXSLT.pm
63 %{perl_vendorarch}/XML/benchmark.pl
64 %dir %{perl_vendorarch}/auto/XML/LibXSLT
65 %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.bs
66 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.so
67 %{_mandir}/man3/*
68 %{_examplesdir}/%{name}-%{version}
This page took 0.177305 seconds and 3 git commands to generate.