]> git.pld-linux.org Git - packages/perl-XML-LibXSLT.git/blob - perl-XML-LibXSLT.spec
- release 4 (by relup.sh)
[packages/perl-XML-LibXSLT.git] / perl-XML-LibXSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXSLT
8 Summary:        XML::LibXSLT - interface to the GNOME libxslt library
9 Summary(pl.UTF-8):      XML::LibXSLT - interfejs do biblioteki libxslt z GNOME
10 Name:           perl-XML-LibXSLT
11 Version:        1.80
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bd8d0eaeee311a6dc148963a3f7753c6
18 URL:            http://search.cpan.org/dist/XML-LibXSLT/
19 BuildRequires:  libxslt-devel >= 1.1.28
20 BuildRequires:  perl-XML-LibXML >= 1.75
21 BuildRequires:  perl-devel >= 1:5.8.1
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 %if "%(perl -MXML::LibXML -e 'print XML::LibXML::LIBXML_VERSION == XML::LibXML::LIBXML_RUNTIME_VERSION || 0' 2>/dev/null)" == "0"
26 BuildRequires:  REBUILD-perl-XML-LibXML
27 %endif
28 %endif
29 Requires:       libxslt >= 1.1.28
30 Requires:       perl-XML-LibXML >= 1.70
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This module is an interface to the GNOME project's libxslt. This is an
35 extremely good XSLT engine, highly compliant and also very fast. I
36 have tests showing this to be more than twice as fast as Sablotron.
37
38 %description -l pl.UTF-8
39 Ten moduł jest interfejsem do libxslt z projektu GNOME. Jest to bardzo
40 dobry silnik XSLT, o dużej zgodności ze standardem, a także bardzo
41 szybki. Według testów jest ponad dwa razy szybszy od Sablotrona.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorarch}/XML/LibXSLT.pm
71 %dir %{perl_vendorarch}/auto/XML/LibXSLT
72 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.so
73 %{_mandir}/man3/*
74 %{_examplesdir}/%{name}-%{version}
This page took 0.088294 seconds and 3 git commands to generate.