]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
- massive attack: source-md5
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML Perl module
9 Summary(cs):    Modul XML::LibXML pro Perl
10 Summary(da):    Perlmodul XML::LibXML
11 Summary(de):    XML::LibXML Perl Modul
12 Summary(es):    Módulo de Perl XML::LibXML
13 Summary(fr):    Module Perl XML::LibXML
14 Summary(it):    Modulo di Perl XML::LibXML
15 Summary(ja):    XML::LibXML Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    XML::LibXML ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul XML::LibXML
18 Summary(pl):    Modu³ Perla XML::LibXML
19 Summary(pt):    Módulo de Perl XML::LibXML
20 Summary(pt_BR): Módulo Perl XML::LibXML
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
22 Summary(sv):    XML::LibXML Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
24 Summary(zh_CN): XML::LibXML Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 %define         _ver    1.54_3
27 Version:        %(echo %{_ver} | sed 's:_:\.:')
28 Release:        3
29 License:        GPL
30 Group:          Development/Languages/Perl
31 #Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
32 Source0:        http://www.cpan.org/authors/id/P/PH/PHISH/%{pdir}-%{pnam}-%{_ver}.tar.gz
33 # Source0-md5:  888d33be26b89ead449b2995a1e2adac
34 Patch0:         %{name}-Makefile.patch
35 BuildRequires:  libxml2-devel >= 2.4.8
36 BuildRequires:  perl-XML-LibXML-Common
37 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
38 BuildRequires:  perl-XML-SAX >= 0.11
39 BuildRequires:  perl-devel >= 5.6.1
40 BuildRequires:  rpm-perlprov >= 4.1-13
41 Requires:       libxml2 >= 2.4.8
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This module implements much of the DOM Level 2 API as an interface to
46 the Gnome libxml2 library. This makes it a fast and highly capable
47 validating XML parser library, as well as a high performance DOM.
48
49 %description -l pl
50 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
51 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
52 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
53
54 %package SAX
55 Summary:        XML::LibXML::SAX perl module
56 Summary(pl):    Modu³ perla XML::LibXML::SAX
57 Group:          Development/Languages/Perl
58 Requires:       %{name} = %{version}
59
60 %description SAX
61 This class allows you to generate SAX2 events using LibXML. Note that
62 this is not a stream based parser, instead it parses documents into a
63 DOM and traverses the DOM tree. The reason being that libxml2's stream
64 based parsing is extremely primitive, and would require an extreme
65 amount of work to allow SAX2 parsing in a stream manner.
66
67 %description SAX -l pl
68 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
69 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
70 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
71 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
72 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
73
74 %prep
75 %setup -q -n %{pdir}-%{pnam}-%{_ver}
76 %patch0 -p1
77
78 %build
79 %{__perl} Makefile.PL \
80         INSTALLDIRS=vendor 
81 %{__make} OPTIMIZE="%{rpmcflags}"
82
83 # dtd test fails for unknown reason
84 %{?_with_tests:%{__make} test}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %{__make} install DESTDIR=$RPM_BUILD_ROOT
91
92 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
95 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
96
97 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
98 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post SAX
104 umask 022
105 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
106
107 %preun SAX
108 umask 022
109 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
110
111 %files
112 %defattr(644,root,root,755)
113 %doc Changes README
114 %{perl_vendorarch}/XML/LibXML.pm
115 %{perl_vendorarch}/XML/LibXML/[^S]*.pm
116 %{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
117 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
118 %{_mandir}/man3/XML::LibXML.3pm*
119 %{_mandir}/man3/XML::LibXML::[^S]*
120 %dir %{_examplesdir}/%{name}-%{version}
121 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
122 %{_examplesdir}/%{name}-%{version}/[^x]*
123
124 %files SAX
125 %defattr(644,root,root,755)
126 %dir %{perl_vendorarch}/XML/LibXML/SAX
127 %{perl_vendorarch}/XML/LibXML/SAX.pm
128 %{perl_vendorarch}/XML/LibXML/SAX/*.pm
129 %{_mandir}/man3/XML::LibXML::SAX.3pm*
130 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.441512 seconds and 4 git commands to generate.