]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
3a9c35a25ea45284f311918247d22b4fe1c562fd
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test" (needs working, not busy /dev/audio!)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML Perl module
9 Summary(cs):    Modul XML::LibXML pro Perl
10 Summary(da):    Perlmodul XML::LibXML
11 Summary(de):    XML::LibXML Perl Modul
12 Summary(es):    Módulo de Perl XML::LibXML
13 Summary(fr):    Module Perl XML::LibXML
14 Summary(it):    Modulo di Perl XML::LibXML
15 Summary(ja):    XML::LibXML Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    XML::LibXML ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul XML::LibXML
18 Summary(pl):    Modu³ Perla XML::LibXML
19 Summary(pt):    Módulo de Perl XML::LibXML
20 Summary(pt_BR): Módulo Perl XML::LibXML
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
22 Summary(sv):    XML::LibXML Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
24 Summary(zh_CN): XML::LibXML Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        1.53
27 Release:        1
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 Patch0:         %{name}-Makefile.patch
32 BuildRequires:  libxml2-devel >= 2.4.8
33 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
34 BuildRequires:  perl-XML-SAX >= 0.11
35 BuildRequires:  perl-devel >= 5.6.1
36 BuildRequires:  rpm-perlprov >= 4.0.2-56
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38 Requires:       libxml2 >= 2.4.8
39
40 %description
41 This module implements much of the DOM Level 2 API as an interface to
42 the Gnome libxml2 library. This makes it a fast and highly capable
43 validating XML parser library, as well as a high performance DOM.
44
45 %description -l pl
46 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
47 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
48 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
49
50 %package SAX
51 Summary:        XML::LibXML::SAX perl module
52 Summary(pl):    Modu³ perla XML::LibXML::SAX
53 Group:          Development/Languages/Perl
54 Requires:       %{name} = %{version}
55
56 %description SAX
57 This class allows you to generate SAX2 events using LibXML. Note that
58 this is not a stream based parser, instead it parses documents into a
59 DOM and traverses the DOM tree. The reason being that libxml2's stream
60 based parsing is extremely primitive, and would require an extreme
61 amount of work to allow SAX2 parsing in a stream manner.
62
63 %description SAX -l pl
64 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
65 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
66 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
67 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
68 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
69
70 %prep
71 %setup -q -n %{pdir}-%{pnam}-%{version}
72 %patch0 -p1
73
74 %build
75 perl Makefile.PL
76 %{__make} OPTIMIZE="%{rpmcflags}"
77
78 %{?_with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 %{__make} install DESTDIR=$RPM_BUILD_ROOT
85
86 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
89 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
90
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
92 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
93
94
95 %post SAX
96 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
97
98 %preun SAX
99 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc Changes README
107 %{perl_sitearch}/XML/LibXML.pm
108 %dir %{perl_sitearch}/XML/LibXML
109 %{perl_sitearch}/XML/LibXML/[^S]*.pm
110 %dir %{perl_sitearch}/auto/XML/LibXML
111 %{perl_sitearch}/auto/XML/LibXML/LibXML.bs
112 %attr(755,root,root) %{perl_sitearch}/auto/XML/LibXML/LibXML.so
113 %{_mandir}/man3/XML::LibXML.3pm.gz
114 %{_mandir}/man3/XML::LibXML::[^S]*
115 %dir %{_examplesdir}/%{name}-%{version}
116 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
117 %{_examplesdir}/%{name}-%{version}/[^x]*
118
119 %files SAX
120 %defattr(644,root,root,755)
121 %dir %{perl_sitearch}/XML/LibXML/SAX
122 %{perl_sitearch}/XML/LibXML/SAX.pm
123 %{perl_sitearch}/XML/LibXML/SAX/*.pm
124 %{_mandir}/man3/XML::LibXML::SAX.3pm*
125 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.030256 seconds and 2 git commands to generate.