]> git.pld-linux.org Git - packages/perl-XML-DOM.git/blob - perl-XML-DOM.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-DOM.git] / perl-XML-DOM.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # tests fail -- buggy perl?
5 %define         pdir    XML
6 %define         pnam    DOM
7 Summary:        XML::DOM - build DOM Level 1 compliant document structures
8 Summary(pl.UTF-8):      XML::DOM - budowanie struktur dokumentów zgodnych z DOM Level 1
9 Name:           perl-XML-DOM
10 Version:        1.44
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1ec2032a06e5762984f7a332c199c205
17 URL:            http://search.cpan.org/dist/XML-DOM/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-XML-Parser >= 2.30
22 BuildRequires:  perl-XML-RegExp
23 BuildRequires:  perl-libwww
24 BuildRequires:  perl-libxml >= 0.07
25 %endif
26 Obsoletes:      perl-libxml-enno
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is a Perl extension to XML::Parser. It adds a new 'Style' to
32 XML::Parser, called 'Dom', that allows XML::Parser to build an Object
33 Oriented datastructure with a DOM Level 1 compliant interface.
34 However, there is a new DOM module, XML::GDOME which is under active
35 development and significantly faster than XML::DOM, since it is based
36 on the libgdome C library.
37
38 %description -l pl.UTF-8
39 To jest rozszerzenie Perla do XML::Parser. Dodaje do XML::Parser nowy
40 styl o nazwie "Dom", pozwalając modułowi budować obiektowo
41 zorientowane struktury danych z interfejsem zgodnym z DOM Level 1.
42 Aczkolwiek jest nowy moduł DOM, XML::GDOME - aktualnie aktywnie
43 rozwijany i znacznie szybszy niż XML::DOM, ponieważ jest oparty na
44 bibliotece C libgdome.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %dir %{perl_vendorlib}/XML/DOM
69 %{perl_vendorlib}/XML/DOM.pm
70 %{perl_vendorlib}/XML/DOM/*.pm
71 %{perl_vendorlib}/XML/Handler/*
72 %{_mandir}/man3/*
This page took 0.064412 seconds and 4 git commands to generate.