]> git.pld-linux.org Git - packages/perl-XML-Catalog.git/blob - perl-XML-Catalog.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-Catalog.git] / perl-XML-Catalog.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    Catalog
7 Summary:        XML::Catalog - Resolve public identifiers and remap system identifiers
8 Summary(pl.UTF-8):      XML::Catalog - rozwiązywanie identyfikatorów publicznych i przemapowywanie systemowych
9 Name:           perl-XML-Catalog
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c2c14f3e87aa75ebb7130ea4ebd41984
17 URL:            http://search.cpan.org/dist/XML-Catalog/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 BuildRequires:  perl-URI
24 BuildRequires:  perl-XML-Parser
25 BuildRequires:  perl-libwww
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module implements draft 0.4 of John Cowan's XML Catalog (formerly
32 known as XCatalog) proposal 
33 (<http://www.ccil.org/~cowan/XML/XCatalog.html>). Catalogs may be
34 written in either SOCAT or XML syntax (see the proposal for syntax
35 details); XML::Catalog will assume SOCAT syntax if the catalog is not
36 in well-formed XML syntax.
37
38 This module, as of 1.0.0, also supports Oasis XML catalogs.
39
40 %description -l pl.UTF-8
41 Ten moduł implementuje szkic (draft) wersji 0.4 propozycji XML Catalog
42 Johna Cowana (wcześniej znanej jako XCatalog:
43 <http://www.ccil.org/~cowan/XML/XCatalog.html>). Katalogi mogą być
44 pisane z użyciem składni SOCAT lub XML (szczegóły w propozycji;
45 XML::Catalog zakłada składnię SOCAT, jeśli katalog nie jest dobrze
46 sformułowanym XML-em).
47
48 Ten moduł w wersji 1.0.0 obsługuje także katalogi Oasis XML.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Build.PL \
55         destdir=$RPM_BUILD_ROOT \
56         installdirs=vendor
57 ./Build
58
59 %{?with_tests:./Build test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 ./Build install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/XML/Catalog.pm
73 %{_mandir}/man3/XML::Catalog.3pm*
This page took 0.135768 seconds and 4 git commands to generate.