]> git.pld-linux.org Git - packages/perl-XML-Atom.git/blob - perl-XML-Atom.spec
3bc265790b0ea6af697e18058a269daab420213c
[packages/perl-XML-Atom.git] / perl-XML-Atom.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    XML
8 %define         pnam    Atom
9 Summary:        perl(XML::Atom)
10 Summary(pl):    perl(XML::Atom)
11 Name:           perl-XML-Atom
12 Version:        0.19
13 Release:        0
14 # "same as perl" according to META.yml
15 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 #Patch0: %{name}
19 URL:            http://search.cpan.org/dist/%{pdir}-%{pnam}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 # most of CPAN modules have generic URL (substitute pdir and pnam here)
23 %if %{with autodeps} || %{with tests}
24 #BuildRequires: perl-
25 #BuildRequires: perl-
26 BuildRequires:  perl-DateTime
27 %endif
28 #Requires:      -
29 #Provides:      -
30 #Obsoletes:     -
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Atom feed and API implementation.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 # yes i know, its crude, but works, and its simple
40 perl -pi -e 's/^auto_install/#auto_install/' Makefile.PL;
41 #%patch0 -p1
42
43 %build
44 # Don't use pipes here: they generally don't work. Apply a patch.
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make}
49 # if module isn't noarch, use:
50 # %{__make} \
51 #       OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/XML/Atom.pm
68 %dir %{perl_vendorlib}/XML/Atom
69 %{perl_vendorlib}/XML/Atom/*.pm
70 %{_mandir}/man3/*
This page took 0.029523 seconds and 2 git commands to generate.