]> git.pld-linux.org Git - packages/perl-WWW-RobotRules.git/blob - perl-WWW-RobotRules.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-WWW-RobotRules.git] / perl-WWW-RobotRules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    WWW
6 %define         pnam    RobotRules
7 Summary:        WWW::RobotRules - database of robots.txt-derived permissions
8 Summary(pl.UTF-8):      WWW::RobotRules - baza danych uprawnień z robots.txt
9 Name:           perl-WWW-RobotRules
10 Version:        6.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/WWW/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b7186e8b8b3701e70c22abf430742403
17 URL:            http://search.cpan.org/dist/WWW-RobotRules/
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-URI >= 1.10
22 %endif
23 Requires:       perl-URI >= 1.10
24 Conflicts:      perl-libwww < 6
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module parses /robots.txt files as specified in "A Standard for
30 Robot Exclusion", at <http://www.robotstxt.org/wc/norobots.html>.
31 Webmasters can use the /robots.txt file to forbid conforming robots
32 from accessing parts of their web site.
33
34 The parsed files are kept in a WWW::RobotRules object, and this object
35 provides methods to check if access to a given URL is prohibited. The
36 same WWW::RobotRules object can be used for one or more parsed
37 /robots.txt files on any number of hosts.
38
39 %description -l pl.UTF-8
40 Ten moduł analizuje pliki /robots.txt opisane w dokumencie "A Standard
41 for Robot Exclusion" (<http://www.robotstxt.org/wc/norobots.html>).
42 Webmasterzy mogą używać pliku /robots.txt, aby zabronić automatom
43 zgodnym z tym standardem dostępu do pewnych plików na stronie WWW.
44
45 Przeanalizowane pliki są trzymane w obiekcie WWW::RobotRules, a obiekt
46 ten udostępnia metody do sprawdzania, czy dostęp do danego URL-a jest
47 zabroniony. Ten sam obiekt WWW::RobotRules może być używany dla
48 jednego lub większej liczby przeanalizowanych plików /robots.txt z
49 różnych hostów.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes
73 %{perl_vendorlib}/WWW/RobotRules.pm
74 %{perl_vendorlib}/WWW/RobotRules
75 %{_mandir}/man3/WWW::RobotRules*.3pm*
This page took 0.183078 seconds and 4 git commands to generate.