]> git.pld-linux.org Git - packages/perl-WWW-Dilbert.git/blob - perl-WWW-Dilbert.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-WWW-Dilbert.git] / perl-WWW-Dilbert.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_with     tests           # perform "make test" (uses network)
5 #
6 %define pdir    WWW
7 %define pnam    Dilbert
8 Summary:        WWW::Dilbert - Retrieve Dilbert of the day comic strip images
9 Summary(pl.UTF-8):      WWW::Dilbert - pobieranie aktualnej strony komiksu "Dilbert of the day"
10 Name:           perl-WWW-Dilbert
11 Version:        1.19
12 Release:        1
13 License:        Apache v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/WWW/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6f1725fde846c27b7a38ca4ea3ed3182
17 URL:            http://search.cpan.org/dist/WWW-Dilbert/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with autodeps} || %{with tests}
21 BuildRequires:  perl-Test-Pod
22 BuildRequires:  perl-Test-Pod-Coverage
23 BuildRequires:  perl-libwww
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module will download the latest Dilbert of the Day cartoon strip
30 from the Dilbert website and return a binary blob of the image, or
31 write it to disk. 
32
33 %description -l pl.UTF-8
34 Ten moduł ściąga ostatnią stronę komiksu "Dilbert of the Day" ze
35 strony WWW Dilberta i zwraca ją w postaci binarnej lub zapisuje na
36 dysk.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 AUTOMATED_TESTING=1
43 export AUTOMATED_TESTING
44 %{__perl} Build.PL \
45         destdir=$RPM_BUILD_ROOT \
46         installdirs=vendor
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes INSTALL TODO
65 %{perl_vendorlib}/WWW/*.pm
66 %{_mandir}/man3/*
67 %{_examplesdir}/%{name}-%{version}
This page took 0.101474 seconds and 3 git commands to generate.