]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blob - perl-Verilog-Perl.spec
perl 5.38.0 rebuild
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
1 # TODO
2 # - should use CXX/CC make options not CC for .cpp compile!
3 # - maybe bin/man1 should be moved to another package
4 #
5 # Conditional build:
6 %bcond_without  tests           # do not perform "make test"
7 #
8 %define pdir    Verilog
9 %define pnam    Perl
10 Summary:        Verilog::Perl - an Perl way to handle Verilog files
11 Summary(pl.UTF-8):      Verilog::Perl - perlowy sposób obsługi plików Verilog
12 Name:           perl-Verilog-Perl
13 Version:        3.416
14 Release:        10
15 License:        LGPL or Perl Artistic License
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Verilog/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  eeae6411b8fd9cdda04fea065065b2ac
19 URL:            http://search.cpan.org/dist/Verilog-Perl/
20 BuildRequires:  flex
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Verilog::Parser, Verilog::Preproc, and other Perl modules useful for
27 manipulation of Verilog files. The Verilog::Parser package will
28 tokenize a Verilog file when the parse() method is called and invoke
29 various callback methods. This is useful for extracting information
30 and editing files while retaining all context. For netlist like
31 extractions, see Verilog::Netlist. Verilog::Preproc reads Verilog
32 files, and preprocesses them according to the Verilog 2001
33 specification. Programs can be easily converted from reading a
34 IO::File into reading preprocessed output from Verilog::Preproc.
35 Verilog::Netlist contains interconnect information about a whole
36 design database.
37
38 %description -l pl.UTF-8
39 Verilog::Parser, Verilog::Preproc i inne moduły Perla przydatne do
40 obróbki plików Verilog. Pakiet Verilog::Parser po wywołaniu metody
41 parse() zamienia plik Verilog na tokeny i wykonuje różne metody
42 wywołań zwrotnych. Jest to przydatne przy wyciąganiu informacji i
43 modyfikowaniu plików z zachowaniem całego kontekstu. Do wyciągania
44 informacji w stylu netlist można użyć Verilog::Netlist.
45 Verilog::Preproc czyta pliki Verilog i przetwarza je zgodnie ze
46 specyfikacją Verilog 2001. Można łatwo przekształcać programy z
47 odczytu za pomocą IO::File na czytanie przetworzonego wyjścia z
48 Verilog::Preproc. Verilog::Netlist zawiera dołączone informacje o
49 całej bazie projektu.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make} \
58         CC="%{__cxx}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Verilog/Verilog-Perl.pod
70 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Verilog/Language/.packlist
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %attr(755,root,root) %{_bindir}/*
79 %dir %{perl_vendorarch}/Verilog
80 %{perl_vendorarch}/Verilog/*.pm
81 %dir %{perl_vendorarch}/Verilog/Netlist
82 %{perl_vendorarch}/Verilog/Netlist/*.pm
83 %dir %{perl_vendorarch}/auto/Verilog
84 %dir %{perl_vendorarch}/auto/Verilog/Preproc
85 %attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.so
86 %dir %{perl_vendorarch}/auto/Verilog/Parser
87 %attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Parser/Parser.so
88 %{_mandir}/man1/*
89 %{_mandir}/man3/*
This page took 0.071848 seconds and 3 git commands to generate.