]> git.pld-linux.org Git - packages/perl-User-Identity.git/blob - perl-User-Identity.spec
- initial
[packages/perl-User-Identity.git] / perl-User-Identity.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    User
7 %define pnam    Identity
8 Summary:        Mail::Identity - an e-mail role
9 #Summary(pl.UTF-8):
10 Name:           perl-User-Identity
11 Version:        0.92
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  35f9582da8bc582a7603299ea27c840f
18 URL:            http://search.cpan.org/dist/User-Identity/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Pod >= 1
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Mail::Identity object contains the description of role played by a
29 human when sending e-mail. Most people have more than one role these
30 days: for instance, a private and a company role with different e-mail
31 addresses.
32
33 An Mail::Identity object combines an e-mail address, user description
34 ("phrase"), a signature, pgp-key, and so on. All fields are optional,
35 and some fields are smart. One such set of data represents one role.
36 Mail::Identity is therefore the smart cousine of the Mail::Address
37 object.
38
39 # %description -l pl.UTF-8 # TODO
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/User/*.pm
64 %{perl_vendorlib}/User/Identity
65 %{perl_vendorlib}/Mail/Identity.pm
66 %{_mandir}/man3/*
This page took 0.102814 seconds and 3 git commands to generate.