]> git.pld-linux.org Git - packages/perl-Unicode-Map.git/blob - perl-Unicode-Map.spec
perl 5.38.0 rebuild
[packages/perl-Unicode-Map.git] / perl-Unicode-Map.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    Map
7 Summary:        Perl Unicode::Map module
8 Summary(pl.UTF-8):      Moduł Perla Unicode::Map
9 Name:           perl-Unicode-Map
10 Version:        0.112
11 Release:        22
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  edaa8fc5ddf0e5d805e274283dd0625d
17 URL:            http://search.cpan.org/dist/Unicode-Map/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl-Startup
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Unicode::Map module converts strings from and to Unicode UCS2 format.
25
26 %description -l pl.UTF-8
27 Moduł Unicode::Map konwertuje łańcuchy znaków na format Unicode UCS2 i
28 odwrotnie.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make} \
37         CC="%{__cc}" \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README Changes
54 %attr(755,root,root) %{_bindir}/*
55 %{perl_vendorarch}/Unicode/Map
56 %{perl_vendorarch}/Unicode/Map.pm
57 %dir %{perl_vendorarch}/auto/Unicode/Map
58 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/Map/Map.so
59 %{_mandir}/man[13]/*
This page took 0.15244 seconds and 4 git commands to generate.