]> git.pld-linux.org Git - packages/perl-URI-Find.git/blame - perl-URI-Find.spec
- new
[packages/perl-URI-Find.git] / perl-URI-Find.spec
CommitLineData
792032b9 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir URI
7%define pnam Find
8Summary: URI::Find - Find URIs in arbitrary text
9#Summary(pl.UTF-8):
10Name: perl-URI-Find
11Version: 0.16
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-authors/id/R/RO/ROSCH/URI-Find-0.16.tar.gz
17# Source0-md5: 339279e268cf37e629f54c1091f99a13
18URL: http://search.cpan.org/dist/URI-Find/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-URI >= 1.00
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This module does one thing: Finds URIs and URLs in plain text. It finds
29them quickly and it finds them all (or what URI::URL considers a URI
30to be.) It only finds URIs which include a scheme (http:// or the
31like), for something a bit less strict have a look at
32URI::Find::Schemeless.
33
34# %description -l pl.UTF-8
35# TODO
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
40%build
41%{__perl} Makefile.PL \
42 INSTALLDIRS=vendor
43%{__make}
44
45%{?with_tests:%{__make} test}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Changes README TODO
59%{perl_vendorlib}/URI/*.pm
60%{perl_vendorlib}/URI/Find
61%{_mandir}/man3/*
This page took 0.081052 seconds and 4 git commands to generate.