]> git.pld-linux.org Git - packages/perl-UNIVERSAL-require.git/blob - perl-UNIVERSAL-require.spec
Up to 0.19.
[packages/perl-UNIVERSAL-require.git] / perl-UNIVERSAL-require.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    UNIVERSAL
6 %define pnam    require
7 Summary:        UNIVERSAL::require - require() modules from a variable
8 Summary(pl.UTF-8):      UNIVERSAL::require - wymaganie modułów ze zmiennej
9 Name:           perl-UNIVERSAL-require
10 Version:        0.19
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/UNIVERSAL/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d0fbbc0eda9bcdc4c77a0f4f1a2bffec
17 URL:            http://search.cpan.org/dist/UNIVERSAL-require/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Conflicts:      perl-UNIVERSAL-exports < 0.03-3
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 If you've ever had to do this...
26
27 eval "require $module";
28
29 to get around the bareword caveats on require(), this module is for
30 you. It creates a universal require() class method that will work with
31 every Perl module and it's secure. So instead of doing some arcane
32 eval() work, you can do this:
33
34 $module->require;
35
36 %description -l pl.UTF-8
37 Jeśli kiedykolwiek było nam potrzebne...
38
39 eval "require $module";
40
41 do obejścia przeciwności require(), ten moduł jest dla nas. Tworzy
42 uniwersalną metodę klasy require() działającą z każdym modułem Perla,
43 a jednocześnie bezpieczną. Czyli zamiast wykonywania jakichś tajemnych
44 działań z eval(), można zrobić:
45
46 $module->require;
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %{perl_vendorlib}/UNIVERSAL/*.pm
71 %{_mandir}/man3/*
This page took 0.076652 seconds and 3 git commands to generate.