]> git.pld-linux.org Git - packages/perl-UNIVERSAL-require.git/blame - perl-UNIVERSAL-require.spec
- initial revision
[packages/perl-UNIVERSAL-require.git] / perl-UNIVERSAL-require.spec
CommitLineData
08cb4faa 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir UNIVERSAL
7%define pnam require
8Summary: UNIVERSAL::require - require() modules from a variable
9#Summary(pl):
10Name: perl-UNIVERSAL-require
11Version: 0.10
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 4ea51136ee7052bb37dc52c7cb8945b0
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20Conflicts: perl-UNIVERSAL-exports <= 0.03
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25If you've ever had to do this...
26
27 eval "require $module";
28
29to get around the bareword caveats on require(), this module is for
30you. It creates a universal require() class method that will work
31with every Perl module and its secure. So instead of doing some
32arcane eval() work, you can do this:
33
34 $module->require;
35
36# %description -l pl
37# TODO
38
39%prep
40%setup -q -n %{pdir}-%{pnam}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes
61%{perl_vendorlib}/UNIVERSAL/*.pm
62%{_mandir}/man3/*
This page took 0.14185 seconds and 4 git commands to generate.