]> git.pld-linux.org Git - packages/perl-Tk.git/commitdiff
- fix linking with X11 auto/th/perl-Tk-804.031-3
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 13 Jun 2013 13:42:11 +0000 (15:42 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 13 Jun 2013 13:42:11 +0000 (15:42 +0200)
- rel 3

perl-Tk-link.patch [new file with mode: 0644]
perl-Tk.spec

diff --git a/perl-Tk-link.patch b/perl-Tk-link.patch
new file mode 100644 (file)
index 0000000..c02f0d5
--- /dev/null
@@ -0,0 +1,185 @@
+--- Tk-804.031/Canvas/Makefile.PL~     2010-05-29 11:55:02.000000000 +0200
++++ Tk-804.031/Canvas/Makefile.PL      2013-06-13 15:24:32.771215659 +0200
+@@ -2,7 +2,7 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      ($^O eq 'MSWin32' ? () : ('LIBS'        => ["-lm"])),
++      ($^O eq 'MSWin32' ? () : ('LIBS'        => ["-lm -lX11"])),
+       'dynamic_ptk' => 1
+       );
+--- Tk-804.031/Compound/Makefile.PL~   2010-05-29 11:55:24.000000000 +0200
++++ Tk-804.031/Compound/Makefile.PL    2013-06-13 15:36:38.135574426 +0200
+@@ -1,3 +1,5 @@
+ use Tk::MMutil;
+-Tk::MMutil::TkExtMakefile('dynamic_ptk' => 1);
++Tk::MMutil::TkExtMakefile(
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]);
+--- Tk-804.031/Entry/Makefile.PL~      2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Entry/Makefile.PL       2013-06-13 15:37:01.075817251 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/HList/Makefile.PL~      2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/HList/Makefile.PL       2013-06-13 15:37:17.855994870 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/InputO/Makefile.PL~     2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/InputO/Makefile.PL      2013-06-13 15:37:34.782840708 +0200
+@@ -2,7 +2,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/Listbox/Makefile.PL~    2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Listbox/Makefile.PL     2013-06-13 15:37:48.489652460 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/Menubutton/Makefile.PL~ 2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Menubutton/Makefile.PL  2013-06-13 15:38:01.246454155 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/Mwm/Makefile.PL~        2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Mwm/Makefile.PL 2013-06-13 15:38:16.663284007 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/NBFrame/Makefile.PL~    2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/NBFrame/Makefile.PL     2013-06-13 15:38:30.380095863 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/Scale/Makefile.PL~      2010-05-29 11:55:02.000000000 +0200
++++ Tk-804.031/Scale/Makefile.PL       2013-06-13 15:38:50.166971968 +0200
+@@ -1,7 +1,7 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      ($^O eq 'MSWin32' ? () : ('LIBS'        => ["-lm"])),
++      ($^O eq 'MSWin32' ? () : ('LIBS'        => ["-lm -lX11"])),
+       'dynamic_ptk' => 1
+       );
+--- Tk-804.031/Scrollbar/Makefile.PL~  2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Scrollbar/Makefile.PL   2013-06-13 15:39:13.013880462 +0200
+@@ -1,5 +1,7 @@
+ use Tk::MMutil;
+-Tk::MMutil::TkExtMakefile('dynamic_ptk' => 1);
++Tk::MMutil::TkExtMakefile('dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
++);
+--- Tk-804.031/TList/Makefile.PL~      2010-05-29 11:55:02.000000000 +0200
++++ Tk-804.031/TList/Makefile.PL       2013-06-13 15:39:25.744015206 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/Text/Makefile.PL~       2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Text/Makefile.PL        2013-06-13 15:39:39.227491255 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/TixGrid/Makefile.PL~    2010-05-29 11:55:02.000000000 +0200
++++ Tk-804.031/TixGrid/Makefile.PL     2013-06-13 15:39:52.847635419 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 1
++      'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
+       );
+--- Tk-804.031/WinPhoto/Makefile.PL~   2010-05-29 11:55:18.000000000 +0200
++++ Tk-804.031/WinPhoto/Makefile.PL    2013-06-13 15:40:15.051203765 +0200
+@@ -1,5 +1,7 @@
+ use Tk::MMutil;
+-Tk::MMutil::TkExtMakefile( 'dynamic_ptk' => 1 );
++Tk::MMutil::TkExtMakefile( 'dynamic_ptk' => 1,
++      'LIBS'        => ["-lX11"]
++);
+--- Tk-804.031/Xlib/Makefile.PL~       2010-05-29 11:54:52.000000000 +0200
++++ Tk-804.031/Xlib/Makefile.PL        2013-06-13 15:40:27.581336389 +0200
+@@ -1,7 +1,8 @@
+ use Tk::MMutil;
+ Tk::MMutil::TkExtMakefile(
+-      'dynamic_ptk' => 0
++      'dynamic_ptk' => 0,
++      'LIBS'        => ["-lX11"]
+       );
index 1c2080824f969ef7b2c6072ec784b30da97b428c..65fc0c88420d5d8d391597d66e6ed5eedbeda659 100644 (file)
@@ -9,7 +9,7 @@ Summary:        Tk - a graphical user interface toolkit for Perl
 Summary(pl.UTF-8):     Tk - toolkit graficznego interfejsu użytkownika dla Perla
 Name:          perl-Tk
 Version:       804.031
-Release:       2
+Release:       3
 # same as perl (except pTk dir - BSD-like)
 License:       GPL v1+ or Artistic, parts BSD-like
 Group:         Development/Languages/Perl
@@ -17,6 +17,7 @@ Source0:      http://www.cpan.org/modules/by-authors/id/S/SR/SREZIC/%{pnam}-%{version
 # Source0-md5: 57a8afd0563184c17a6470d1ee957f35
 Patch0:                %{name}-misc.patch
 Patch1:                %{name}-man_section.patch
+Patch2:                %{name}-link.patch
 URL:           http://search.cpan.org/dist/Tk/
 BuildRequires: perl-Tie-Watch
 BuildRequires: perl-devel >= 1:5.8.0
@@ -58,6 +59,7 @@ graficznego interfejsu użytkownika Tk.
 %setup -q -n %{pnam}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 # sync with current Xlib
This page took 0.114729 seconds and 4 git commands to generate.