]> git.pld-linux.org Git - packages/perl-Tie-IxHash.git/blob - perl-Tie-IxHash.spec
- formatting
[packages/perl-Tie-IxHash.git] / perl-Tie-IxHash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Tie
7 %define         pnam    IxHash
8 Summary:        Tie::IxHash - ordered associative arrays for Perl
9 Summary(pl):    Tie::IxHash - uporz±dkowane tablica asocjacyjne dla Perla
10 Name:           perl-Tie-IxHash
11 Version:        1.21
12 Release:        11
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  567ddc13081596b52cfe3d82218cb264
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This Perl module implements Perl hashes that preserve the order in
25 which the hash elements were added. The order is not affected when
26 values corresponding to existing keys in the IxHash are changed. The
27 elements can also be set to any arbitrary supplied order. The familiar
28 perl array operations can also be performed on the IxHash.
29
30 %description -l pl
31 Ten modu³ Perla jest implementacj± haszy, które zachowuj± kolejno¶æ, w
32 jakiej elementy by³y dodawane. Kolejno¶æ nie ulega zmianie kiedy
33 modyfikowane s± warto¶ci odpowiadaj±ce istniej±cym kluczom w obiekcie
34 IxHash. Elementy mog± byæ tak¿e ustawiane w zadanej kolejno¶ci. Znane
35 operacje na tablicach perlowych mog± byæ tak¿e wykonywane na typie
36 IxHash.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Tie/IxHash.pm
61 %{_mandir}/man3/*
This page took 0.202959 seconds and 3 git commands to generate.