]> git.pld-linux.org Git - packages/perl-Text-VimColor.git/blob - perl-Text-VimColor.spec
- up to 0.11
[packages/perl-Text-VimColor.git] / perl-Text-VimColor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Text
7 %define         pnam    VimColor
8 Summary:        Text::VimColor - syntax color text in HTML or XML using Vim
9 Summary(pl):    Text::VimColor - kolorowanie sk³adni tekstu w HTML-u lub XML-u przy u¿yciu Vima
10 Name:           perl-Text-VimColor
11 Version:        0.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  268fb3f630b463fcec528d798dcf77c3
18 %if %{with tests}
19 BuildRequires:  perl-Path-Class
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module tries to markup text files according to their syntax. It
28 can be used to produce web pages with pretty-printed colourful source
29 code samples. It can produce output in the following formats:
30 - HTML 
31  Valid XHTML 1.0, with the exact colouring and style left to a CSS
32  stylesheet
33 - XML 
34  Pieces of text are marked with XML elements in a simple vocabulary,
35  which can be converted to other formats, for example, using XSLT
36 - Perl array 
37  A simple Perl data structure, so that Perl code can be used to turn
38  it into whatever is needed
39 This module works by running the Vim text editor and getting it to
40 apply its excellent syntax highlighting (aka 'font-locking') to an
41 input file, and mark pieces of text according to whether it thinks
42 they are comments, keywords, strings, etc.
43
44 %description -l pl
45 Ten modu³ próbuje oznaczyæ pliki tekstowe zgodnie z ich sk³adni±. Mo¿e
46 byæ u¿ywany do tworzenia stron WWW z ³adnie wydrukowanymi, kolorowymi
47 przyk³adami kodu ¼ród³owego. Modu³ mo¿e tworzyæ wynik w nastêpuj±cych
48 formatach:
49 - HTML - poprawny XHTML 1.0, z dok³adnym kolorowaniem i stylem
50   pozostawionym dla arkusza CSS
51 - XML - fragmenty tekstu oznaczane elementami XML-a z prostym
52   s³ownictwem; mo¿na to skonwertowaæ do innych formatów, na przyk³ad
53   przy u¿yciu XSLT
54 - tablica perlowa - prosta struktura danych w Perlu, dziêki czemu
55   mo¿na u¿yæ perlowego kodu do przekszta³cenia jej w co tylko
56   potrzeba.
57 Ten modu³ dzia³a poprzez uruchomienie edytora tekstu Vim i zmuszenie
58 go do zastosowania swojego ¶wietnego pod¶wietlania sk³adni (znanego
59 tak¿e jako 'font-locking') dla pliku wej¶ciowego oraz oznaczenia
60 fragmentów tekstu zale¿nie od tego, czy uwa¿a je za komentarze, s³owa
61 kluczowe, ³añcuchy itp.
62
63 %prep
64 %setup -q -n %{pdir}-%{pnam}-%{version}
65
66 %build
67 %{__perl} Makefile.PL \
68         INSTALLDIRS=vendor
69 %{__make}
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc ChangeLog README
85 %attr(755,root,root) %{_bindir}/*
86 %{perl_vendorlib}/Text/*
87 %{_mandir}/man3/*
88 %{_mandir}/man1/*
This page took 0.088282 seconds and 4 git commands to generate.