]> git.pld-linux.org Git - packages/perl-Text-VimColor.git/blob - perl-Text-VimColor.spec
86cc41193246ce6d8bec8c5635d7c827a001b174
[packages/perl-Text-VimColor.git] / perl-Text-VimColor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    VimColor
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Text::VimColor - syntax color text in HTML or XML using Vim
9 Summary(pl.UTF-8):      Text::VimColor - kolorowanie składni tekstu w HTML-u lub XML-u przy użyciu Vima
10 Name:           perl-Text-VimColor
11 Version:        0.11
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  268fb3f630b463fcec528d798dcf77c3
18 URL:            http://search.cpan.org/dist/Text-VimColor/
19 %if %{with tests}
20 BuildRequires:  perl-Path-Class
21 BuildRequires:  vim
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module tries to markup text files according to their syntax. It
30 can be used to produce web pages with pretty-printed colourful source
31 code samples. It can produce output in the following formats:
32 - HTML Valid XHTML 1.0, with the exact colouring and style left to a
33   CSS stylesheet
34 - XML Pieces of text are marked with XML elements in a simple
35   vocabulary, which can be converted to other formats, for example,
36   using XSLT
37 - Perl array A simple Perl data structure, so that Perl code can be
38   used to turn it into whatever is needed This module works by running
39   the Vim text editor and getting it to apply its excellent syntax
40   highlighting (aka 'font-locking') to an input file, and mark pieces of
41   text according to whether it thinks they are comments, keywords,
42   strings, etc.
43
44 %description -l pl.UTF-8
45 Ten moduł próbuje oznaczyć pliki tekstowe zgodnie z ich składnią. Może
46 być używany do tworzenia stron WWW z ładnie wydrukowanymi, kolorowymi
47 przykładami kodu źródłowego. Moduł może tworzyć wynik w następujących
48 formatach:
49 - HTML - poprawny XHTML 1.0, z dokładnym kolorowaniem i stylem
50   pozostawionym dla arkusza CSS
51 - XML - fragmenty tekstu oznaczane elementami XML-a z prostym
52   słownictwem; można to skonwertować do innych formatów, na przykład
53   przy użyciu XSLT
54 - tablica perlowa - prosta struktura danych w Perlu, dzięki czemu
55   można użyć perlowego kodu do przekształcenia jej w co tylko potrzeba.
56   Ten moduł działa poprzez uruchomienie edytora tekstu Vim i zmuszenie
57   go do zastosowania swojego świetnego podświetlania składni (znanego
58   także jako 'font-locking') dla pliku wejściowego oraz oznaczenia
59   fragmentów tekstu zależnie od tego, czy uważa je za komentarze, słowa
60   kluczowe, łańcuchy itp.
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-%{version}
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor
68 %{__make}
69
70 %{?with_tests:%{__make} test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc ChangeLog README
84 %attr(755,root,root) %{_bindir}/*
85 %{perl_vendorlib}/Text/*
86 %{_mandir}/man3/*
87 %{_mandir}/man1/*
This page took 0.055982 seconds and 2 git commands to generate.