]> git.pld-linux.org Git - packages/perl-Text-Soundex.git/blob - perl-Text-Soundex.spec
perl 5.38.0 rebuild
[packages/perl-Text-Soundex.git] / perl-Text-Soundex.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Text
6 %define         pnam    Soundex
7 Summary:        Text::Soundex - Implementation of the soundex algorithm
8 Summary(pl.UTF-8):      Text::Soundex - implementacja algorytmu soundex
9 Name:           perl-Text-Soundex
10 Version:        3.05
11 Release:        6
12 License:        free (see COPYING)
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  cb40ded7a5d27aa3a411d274d6ec18ae
16 URL:            https://metacpan.org/dist/Text-Soundex
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Soundex is a phonetic algorithm for indexing names by sound, as
24 pronounced in English. The goal is for names with the same
25 pronunciation to be encoded to the same representation so that they
26 can be matched despite minor differences in spelling. Soundex is the
27 most widely known of all phonetic algorithms and is often used
28 (incorrectly) as a synonym for "phonetic algorithm". Improvements to
29 Soundex are the basis for many modern phonetic algorithms. (Wikipedia,
30 2007)
31
32 This module implements the original soundex algorithm developed by
33 Robert Russell and Margaret Odell, patented in 1918 and 1922, as well
34 as a variation called "American Soundex" used for US census data, and
35 current maintained by the National Archives and Records Administration
36 (NARA).
37
38 The soundex algorithm may be recognized from Donald Knuth's
39 The Art of Computer Programming. The algorithm described by
40 Knuth is the NARA algorithm.
41
42 %description -l pl.UTF-8
43 Soundex to algorytm fonetyczny do indeksowania nazw według brzmienia w
44 języku angielskim. Celem jest, aby nazwy o tej samej wymowie miały
45 taką samą reprezentację, przez co mogą być dopasowane niezależnie od
46 niewielkich różnic w pisowni. Soundex to najbardziej znany algorytm
47 fonetyczny, zwykle używany (niewłaściwie) jako synonim algorytmu
48 fonetycznego. (Wikipedia angielska, 2007)
49
50 Ten moduł implementuje oryginalny algorytm soundex opracowany przez
51 Roberta Russella oraz Margaret Odell, opatentowany w 1918 i 1922, oraz
52 wariację o nazwie "soundex amerykański" używany dla danych ludności w
53 USA, obecnie zarządzany przez NARA (National Archives and Records
54 Administration).
55
56 Algorytm soundex można znaleźć w "The Art of Computer Programming"
57 Donalda Knutha. Algorytm opisany przez Knutha to algorytm NARA.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 # extract copyright information
63 %{__sed} -n -e '3,12p' Soundex.pm > COPYING
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor
68 %{__make} \
69         CC="%{__cc}" \
70         OPTIMIZE="%{rpmcflags}"
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} pure_install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc COPYING Changes
86 %{perl_vendorarch}/Text/Soundex.pm
87 %dir %{perl_vendorarch}/auto/Text/Soundex
88 %attr(755,root,root) %{perl_vendorarch}/auto/Text/Soundex/Soundex.so
89 %{_mandir}/man3/Text::Soundex.3pm*
This page took 0.096905 seconds and 4 git commands to generate.