]> git.pld-linux.org Git - packages/perl-Text-Glob.git/blob - perl-Text-Glob.spec
- macros for perl autodeps
[packages/perl-Text-Glob.git] / perl-Text-Glob.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Text
6 %define         pnam    Glob
7 Summary:        Text::Glob perl module - match globbing patterns against text
8 Summary(pl.UTF-8):      Moduł perla Text::Glob - dopasowywanie tekstu do wzorców
9 Name:           perl-Text-Glob
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d001559c504a2625dd117bd1558f07f7
17 URL:            https://metacpan.org/release/Text-Glob
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Text::Glob implements glob(3) style matching that can be used to match
29 against text, rather than fetching names from a filesystem. If you
30 want to do full file globbing use the File::Glob module instead.
31
32 %description -l pl.UTF-8
33 Text::Glob jest implementacją dopasowywania w stylu glob(3), które
34 może być używane do dopasowywania tekstu, a nie nazw plików. Jeśli
35 potrzeba pełnej implementacji glob dla plików, należy użyć modułu
36 File::Glob zamiast tego.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %{perl_vendorlib}/Text/Glob.pm
61 %{_mandir}/man3/Text::Glob.3pm*
This page took 0.196573 seconds and 4 git commands to generate.