]> git.pld-linux.org Git - packages/perl-Test-WWW-Selenium.git/blob - perl-Test-WWW-Selenium.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-WWW-Selenium.git] / perl-Test-WWW-Selenium.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    WWW-Selenium
7 Summary:        Test::WWW::Selenium - Test applications using Selenium Remote Control
8 Name:           perl-Test-WWW-Selenium
9 Version:        1.25
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  e1dc1e8ee1cf83ad188f38604d1ad95b
15 URL:            http://search.cpan.org/dist/Test-WWW-Selenium/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-libwww
20 BuildRequires:  perl-URI
21 BuildRequires:  perl(Test::Exception)
22 BuildRequires:  perl(Test::Mock::LWP)
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is a WWW::Selenium subclass providing some methods
29 useful for writing tests. For each Selenium command (open, click,
30 type, ...) there is a corresponding <command>_ok method that
31 checks the return value (open_ok, click_ok, type_ok).
32
33 For each Selenium getter (get_title, ...) there are four autogenerated
34 methods (<getter>_is, <getter>_isnt, <getter>_like,
35 <getter>_unlike) to check the value of the attribute.
36
37 By calling the constructor with default_names set to a true value your
38 tests will be given a reasonable name should you choose not to provide
39 one of your own.  The test name should always be the third argument.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README todo.txt
63 %{perl_vendorlib}/Test/WWW/*.pm
64 %{perl_vendorlib}/Test/WWW/*.pl
65 %dir %{perl_vendorlib}/WWW
66 %{perl_vendorlib}/WWW/*.pm
67 %dir %{perl_vendorlib}/WWW/Selenium
68 %{perl_vendorlib}/WWW/Selenium/*.pm
69 %{_mandir}/man3/*
This page took 0.098882 seconds and 4 git commands to generate.