]> git.pld-linux.org Git - packages/perl-Test-Unit.git/blob - perl-Test-Unit.spec
- spaces -> tabs
[packages/perl-Test-Unit.git] / perl-Test-Unit.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Unit
8 Summary:        Test::Unit Perl module
9 Summary(cs):    Modul Test::Unit pro Perl
10 Summary(da):    Perlmodul Test::Unit
11 Summary(de):    Test::Unit Perl Modul
12 Summary(es):    Módulo de Perl Test::Unit
13 Summary(fr):    Module Perl Test::Unit
14 Summary(it):    Modulo di Perl Test::Unit
15 Summary(ja):    Test::Unit Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    Test::Unit ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul Test::Unit
18 Summary(pl):    Modu³ Perla Test::Unit
19 Summary(pt):    Módulo de Perl Test::Unit
20 Summary(pt_BR): Módulo Perl Test::Unit
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl Test::Unit
22 Summary(sv):    Test::Unit Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl Test::Unit
24 Summary(zh_CN): Test::Unit Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        0.24
27 Release:        3
28 License:        GPL/Artistic
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 BuildRequires:  perl >= 5
32 %if %{!?_without_tests:1}0
33 BuildRequires:  perl-Class-Inner
34 BuildRequires:  perl-Devel-Symdump
35 BuildRequires:  perl-Error
36 %endif
37 BuildRequires:  rpm-perlprov >= 4.0.2-104
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # optional (for Test::Unit::TkTestRunner only)
42 # (or maybe create subpackage with TkTestRunner?)
43 %define         _noautoreq      'perl(Tk.*)'
44
45 %description
46 This framework is intended to support unit testing in an object-oriented
47 development paradigm (with support for inheritance of tests etc.) and
48 is derived from the JUnit testing framework for Java by Kent Beck and
49 Erich Gamma.
50
51 %description -l pl
52 Ten pakiet udostêpnia szkielet do obs³ugi testów poszczególnych czê¶ci
53 obiektowo zorientowanej aplikacji (z obs³ug± dziedziczenia testów, itp.).
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL
60 %{__make}
61
62 %{!?_without_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install DESTDIR=$RPM_BUILD_ROOT
68
69 gzip -9nf examples/README
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Change* AUTHORS
79 %attr(755,root,root) %{perl_sitelib}/%{pdir}/*.pl
80 %{perl_sitelib}/%{pdir}/*.pm
81 %dir %{perl_sitelib}/%{pdir}/%{pnam}
82 %{perl_sitelib}/%{pdir}/%{pnam}/*
83 %{_mandir}/man3/*
84 %dir %{_examplesdir}/%{name}-%{version}
85 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/p*
86 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/tester.pl
87 %{_examplesdir}/%{name}-%{version}/tester.png
88 %{_examplesdir}/%{name}-%{version}/[RE]*
This page took 0.082146 seconds and 3 git commands to generate.