]> git.pld-linux.org Git - packages/perl-Test-SubCalls.git/blob - perl-Test-SubCalls.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-SubCalls.git] / perl-Test-SubCalls.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Test
6 %define pnam    SubCalls
7 Summary:        Test::SubCalls - Track the number of times subs are called
8 Summary(pl.UTF-8):      Test::SubCalls - śledzi liczbę razy ile został wywołany podprogram
9 Name:           perl-Test-SubCalls
10 Version:        1.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/ADAMK/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  975a9fe8d93ef0298fc1bca8f03166e1
17 URL:            http://search.cpan.org/dist/Test-SubCalls/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-Hook-LexWrap >= 0.20
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 There are a number of different situations (like testing caching code)
29 where you want to want to do a number of tests, and then verify that
30 some underlying subroutine deep within the code was called a specific
31 number of times.
32
33 This module provides a number of functions for doing testing in this
34 way in association with your normal Test::More (or similar) test
35 scripts.
36
37 %description -l pl.UTF-8
38 Są różne sytuacje (jak testowanie kodu cache'ującego), kiedy chcemy
39 wykonać ileś testów, a następnie sprawdzić, że jakaś zagnieżdżona
40 procedura została wywołana ileś razy.
41
42 Ten moduł udostępnia funkcje do wykonywania takich testów w zwykłych
43 skryptach testowych Test::More (lub podobnych).
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/Test/SubCalls.pm
68 %{_mandir}/man3/Test::SubCalls.3pm*
This page took 0.073861 seconds and 4 git commands to generate.