]> git.pld-linux.org Git - packages/perl-Test-SharedFork.git/blob - perl-Test-SharedFork.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-SharedFork.git] / perl-Test-SharedFork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    SharedFork
7 Summary:        Test::SharedFork - fork test
8 Summary(pl.UTF-8):      Test::SharedFork - testowanie funkcji fork
9 Name:           perl-Test-SharedFork
10 Version:        0.35
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3101aea2e3ae41d48fd8874414430cef
17 URL:            http://search.cpan.org/dist/Test-SharedFork/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.64
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Requires
23 BuildRequires:  perl-Test-Simple >= 0.88
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Test::SharedFork is utility module for Test::Builder.
30
31 This module makes fork(2) safety in your test case.
32
33 This module merges test count with parent process & child process.
34
35 %description -l pl.UTF-8
36 Test::SharedFork to moduł narzędziowy dla modułu Test::Builder.
37
38 Ten moduł czyni wywołanie fork(2) bezpiecznym w przypadkach testowych.
39 Łączy liczbę testów z procesu rodzica z procesami potomnymi.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README.md
63 %{perl_vendorlib}/Test/SharedFork.pm
64 %{perl_vendorlib}/Test/SharedFork
65 %{_mandir}/man3/Test::SharedFork.3pm*
This page took 0.059415 seconds and 4 git commands to generate.