]> git.pld-linux.org Git - packages/perl-Test-Requires.git/blob - perl-Test-Requires.spec
- updated to 0.10
[packages/perl-Test-Requires.git] / perl-Test-Requires.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Requires
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::Requires - checks to see if the module can be loaded
9 Summary(pl.UTF-8):      Test::Requires - sprawdzanie, czy moduł może być załadowany
10 Name:           perl-Test-Requires
11 Version:        0.10
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  0d5da779609d0c8fa6f796b45ff8c6f3
18 URL:            http://search.cpan.org/dist/Test-Requires/
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.64
20 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.61}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Test::Requires checks to see if the module can be loaded.
28
29 If this fails rather than failing tests this skips all tests.
30
31 %description -l pl.UTF-8
32 Test::Requires sprawdza, czy moduł może być załadowany.
33
34 Jeśli to nie powiedzie się, to zamiast niepowodzeń przy uruchamianiu
35 testów pomijane są wszystkie testy.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %{perl_vendorlib}/Test/Requires.pm
60 %{_mandir}/man3/Test::Requires.3pm*
This page took 0.187224 seconds and 4 git commands to generate.