]> git.pld-linux.org Git - packages/perl-Test-Prereq.git/blob - perl-Test-Prereq.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Prereq.git] / perl-Test-Prereq.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (seem not to work - for unknown reason)
4 #
5 %define         pdir    Test
6 %define         pnam    Prereq
7 Summary:        Test::Prereq Perl module - check if Makefile.PL has the right pre-requisites
8 Summary(pl.UTF-8):      Moduł Perla Test::Prereq - sprawdzanie, czy spełnione są zależności podane w Makefile.PL
9 Name:           perl-Test-Prereq
10 Version:        1.037
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d38be5a57b38cf500a7c2a212fb697e9
17 URL:            http://search.cpan.org/dist/Test-Prereq/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-File-Find-Rule
21 BuildRequires:  perl-Module-CoreList
22 BuildRequires:  perl-Test-Manifest >= 0.9
23 BuildRequires:  perl-Test-Pod
24 BuildRequires:  perl-Test-Simple
25 BuildRequires:  perl(Test::Builder::Tester)
26 %endif
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 Obsoletes:      perl-Test-Prereq-Build
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The prereq_ok() function examines the modules it finds in blib/lib/
34 and the test files it finds in t/. It figures out which modules they
35 use, skips the modules that are in the Perl core, and compares the
36 remaining list of modules to those in the PREREQ_PM section of
37 Makefile.PL.
38
39 THIS IS ALPHA SOFTWARE. IT HAS SOME PROBLEMS.
40
41 %description -l pl.UTF-8
42 Funkcja prereq_ok() sprawdza moduły, które znajdzie w blib/lib/ oraz
43 pliki testów, które znajdzie w t/. Określa, których modułów używają,
44 pomija moduły należące do podstawowego Perla i porównuje listę modułów
45 z tymi podanymi w sekcji PREREQ_PM w Makefile.PL.
46
47 TO JEST OPROGRAMOWANIE ALPHA. MA TROCHĘ PROBLEMÓW.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/Test/*.pm
72 %dir %{perl_vendorlib}/Test/Prereq
73 %{perl_vendorlib}/Test/Prereq/*.pm
74 %{_mandir}/man3/*
This page took 0.139427 seconds and 4 git commands to generate.