]> git.pld-linux.org Git - packages/perl-Test-Portability-Files.git/blob - perl-Test-Portability-Files.spec
- created with pldcpan
[packages/perl-Test-Portability-Files.git] / perl-Test-Portability-Files.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Portability-Files
8 Summary:        Test::Portability::Files - Check file names portability
9 Name:           perl-Test-Portability-Files
10 Version:        0.05
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2ede77af4d3b82ffb39cd28fda6857e5
17 URL:            http://search.cpan.org/dist/Test-Portability-Files/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is used to check the portability across operating systems
28 of the names of the files present in the distribution of a module. The
29 tests use the advices given in perlport/"Files and Filesystems". The
30 author of a distribution can select which tests to execute.
31
32 To use this module, simply copy the code from the synopsis in a test
33 file named t/portfs.t for example, and add it to your MANIFEST. You
34 can delete the call to options() to enable only most common tests.
35
36 By default, not all tests are enabled because some are judged too
37 cumbersome to be practical, especially since some of the most limited
38 platforms (like MS-DOS) seem to be no longer supported.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Build.PL \
45         destdir=$RPM_BUILD_ROOT \
46         installdirs=vendor
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 ./Build install
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorlib}/Test/Portability
62 %{perl_vendorlib}/Test/Portability/*.pm
63 %{_mandir}/man3/*
This page took 0.056999 seconds and 3 git commands to generate.