]> git.pld-linux.org Git - packages/perl-Test-Manifest.git/blob - perl-Test-Manifest.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Manifest.git] / perl-Test-Manifest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Manifest
7 Summary:        Test::Manifest - interact with a t/test_manifest file
8 Summary(pl.UTF-8):      Test::Manifest - współpraca z plikiem t/test_manifest
9 Name:           perl-Test-Manifest
10 Version:        1.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  81c8744987b67d35af05a74a3c7f1742
17 URL:            http://search.cpan.org/dist/Test-Manifest/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 MakeMaker assumes that you want to run all of the .t files in the t/
28 directory in ascii-betical order during make test unless you say
29 otherwise. This leads to some interesting naming schemes for test
30 files to get them in the desired order.
31
32 %description -l pl.UTF-8
33 MakeMaker zakłada, że chcemy podczas make test uruchamiać wszystkie
34 pliki .t z katalogu t/ w kolejności asciibetycznej, o ile nie podamy
35 innej kolejności. To prowadzi do interesujących schematów nazywania
36 plików z testami, aby były wykonywane we właściwej kolejności.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{perl_vendorlib}/Test/Manifest.pm
This page took 0.084229 seconds and 4 git commands to generate.