]> git.pld-linux.org Git - packages/perl-Test-Fork.git/blob - perl-Test-Fork.spec
- new
[packages/perl-Test-Fork.git] / perl-Test-Fork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Test
6 %define         pnam    Fork
7 Summary:        Test::Fork - test code which forks
8 Summary(pl.UTF-8):      Test::Fork - testowanie kodu, który rozgałęzia procesy
9 Name:           perl-Test-Fork
10 Version:        0.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ac77c9fec0f933db312d7b2fc9b3e7d1
17 URL:            https://metacpan.org/release/Test-Fork
18 BuildRequires:  perl-Module-Build >= 0.2808
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(Test::Builder::Module) >= 0.02
24 BuildRequires:  perl-Test-Builder-Tester >= 1.02
25 BuildRequires:  perl-Test-Simple >= 0.62
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 THIS IS ALPHA CODE! The implementation is unreliable and the interface
32 is subject to change.
33
34 Because each test has a number associated with it, testing code which
35 forks is problematic. Coordinating the test number amongst the parent
36 and child processes is complicated. Test::Fork provides a function to
37 smooth over the complications.
38
39 %description -l pl.UTF-8
40 TEN KOD JEST W STADIUM ALFA! Implementacja nie jest wiarygodna, a
41 interfejs może się zmienić.
42
43 Ponieważ każdy test ma powiązaną ze sobą liczbę, testowanie kodu,
44 który rozgałęzia procesy (wykonuje fork), jest problematyczne.
45 Koordynowanie numerów testów między procesy rodzica i potomka jest
46 skomplikowane. Test::Fork dostarcza funkcję, która zaciera te
47 komplikacje.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Build.PL \
54         destdir=$RPM_BUILD_ROOT \
55         installdirs=vendor
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/Test/Fork.pm
72 %{_mandir}/man3/Test::Fork.3pm*
This page took 0.187775 seconds and 4 git commands to generate.