]> git.pld-linux.org Git - packages/perl-Test-Expect.git/blob - perl-Test-Expect.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Expect.git] / perl-Test-Expect.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %define pdir    Test
6 %define pnam    Expect
7 Summary:        Test::Expect - Automated driving and testing of terminal-based programs
8 Summary(pl.UTF-8):      Test::Expect - Automatyczne sterowanie i testowanie programów terminalowych
9 Name:           perl-Test-Expect
10 Version:        0.31
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2d30b1be2e5e390a9aa698858607e428
17 URL:            http://search.cpan.org/dist/Test-Expect/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Expect-Simple
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Test::Expect is a module for automated driving and testing of
29 terminal-based programs.  It is handy for testing interactive programs
30 which have a prompt, and is based on the same concepts as the Tcl
31 Expect tool.  As in Expect::Simple, the Expect object is made
32 available for tweaking.
33
34 Test::Expect is intended for use in a test script.
35
36 %description -l pl.UTF-8
37 Test::Expect to moduł do automatycznego sterowania i testowania
38 programów terminalowych. Jest poręczny przy testowaniu programów
39 interaktywnych mających znak zachęty i jest oparty na tych samych
40 ideach co narzędzie Expect z Tcl-a. Podobnie jak w Expect::Simple
41 obiekt Expect jest dostępny w razie potrzeby.
42
43 Test::Expect jest przeznaczony do używania w skryptach testowych.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CHANGES README
67 %{perl_vendorlib}/Test/*.pm
68 %{_mandir}/man3/*
This page took 0.38717 seconds and 4 git commands to generate.