]> git.pld-linux.org Git - packages/perl-Test-EOL.git/blob - perl-Test-EOL.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-EOL.git] / perl-Test-EOL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    EOL
7 Summary:        Test::EOL - Check the correct line endings in your project
8 Name:           perl-Test-EOL
9 Version:        1.5
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d6ae3b338c034dc747458ed0a5fb6667
16 URL:            http://search.cpan.org/dist/Test-EOL/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module scans your project/distribution for any perl files (scripts,
26 modules, etc) for the presence of windows line endings.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make}
35
36 %{?with_tests:%{__make} test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} pure_install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changes README
50 %{perl_vendorlib}/Test/*.pm
51 %{_mandir}/man3/*
This page took 0.14388 seconds and 3 git commands to generate.