]> git.pld-linux.org Git - packages/perl-Term-Screen.git/blob - perl-Term-Screen.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Term-Screen.git] / perl-Term-Screen.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %define         pdir    Term
6 %define         pnam    Screen
7 Summary:        Term::Screen - a simple all Perl Term::Cap based screen positioning module
8 Summary(pl.UTF-8):      Term::Screen - prosty perlowy moduł pozycjonowania ekranu oparty na Term::Cap
9 Name:           perl-Term-Screen
10 Version:        1.03
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1a57d3aa267d613a8897933a99f7110e
17 Patch0:         %{name}-test.patch
18 URL:            http://search.cpan.org/dist/Term-Screen/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Term::Screen is a very simple screen positioning module that should
26 work wherever "Term::Cap" does. It is set up for Unix using stty's but
27 these dependences are isolated by evals in the "new" constructor. Thus
28 you may create a child module implementing Screen with MS-DOS, ioctl,
29 or other means to get raw and unblocked input. This is not a
30 replacement for Curses - it has no memory. This was written so that it
31 could be easily changed to fit nasty systems, and to be available
32 first thing.
33
34 %description -l pl.UTF-8
35 Term::Screen to bardzo prosty moduł do pozycjonowania ekranu, który
36 powinien działać zawsze kiedy Term::Cap działa. Jest skonfigurowany
37 dla Uniksów i używania stty, ale te zależności są wydzielone do
38 instrukcji eval w konstruktorze new. W ten sposób można stworzyć moduł
39 potomny implementujący Screen dla MS-DOS-a, przy użyciu ioctl-i, albo
40 w inny sposób uzyskując surowe i nieblokujące wejście. Nie jest to
41 zamiennik Curses - nie ma pamięci. Został napisany tak, aby mógł być
42 łatwo dopasowany do paskudnych systemów i być pierwszą dostępną
43 rzeczą.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %patch0 -p1
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %{perl_vendorlib}/Term/Screen.pm
69 %{_mandir}/man3/*
This page took 0.125511 seconds and 4 git commands to generate.