]> git.pld-linux.org Git - packages/perl-Term-ReadLine-Perl.git/blob - perl-Term-ReadLine-Perl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Term-ReadLine-Perl.git] / perl-Term-ReadLine-Perl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # interactive
5
6 %define         pdir    Term
7 %define         pnam    ReadLine-Perl
8 Summary:        Term::ReadLine::Perl - minimal interface to Readline libraries
9 Summary(pl.UTF-8):      Term::ReadLine::Perl - minimalny interfejs do bibliotek Readline
10 Name:           perl-Term-ReadLine-Perl
11 Version:        1.0303
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a77ecf4921cc714820fef898c6cb0eaf
18 URL:            http://search.cpan.org/dist/Term-ReadLine-Perl/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Term-ReadKey
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Term::ReadLine::Perl module is a quick implementation of the minimal
28 interface to Readline libraries. The implementation is made in Perl
29 (mostly) by Jeffrey Friedl. The only thing this library does is to
30 make it conformant (and add some minimal changes, like using
31 Term::ReadKey if present, and correct work under xterm).
32
33 %description -l pl.UTF-8
34 Moduł Term::ReadLine::Perl jest szybką implementacją minimalnego
35 interfejsu do bibliotek Readline. Implementacja w Perlu została w
36 większości wykonana przez Jeffreya Friedla. Jedyną rzeczą, jaką robi
37 ta biblioteka, jest bycie zgodnym (i dodanie pewnych minimalnych
38 zmian, w rodzaju używania Term::ReadKey jeśli istnieje oraz poprawnej
39 pracy na xtermie).
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README CHANGES
63 %{perl_vendorlib}/Term/ReadLine/*.pm
This page took 0.0956900000000001 seconds and 4 git commands to generate.