]> git.pld-linux.org Git - packages/perl-Sys-Load.git/blob - perl-Sys-Load.spec
perl 5.38.0 rebuild
[packages/perl-Sys-Load.git] / perl-Sys-Load.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Sys
6 %define         pnam    Load
7 Summary:        Sys::Load - Perl module for getting the current system load and uptime
8 Summary(pl.UTF-8):      Sys::Load - moduł Perla do odczytywania obciążenia systemu i uptime'u
9 Name:           perl-Sys-Load
10 Version:        0.2
11 Release:        21
12 # sae as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  370372db0ddbcde3725049157e0bc5ad
17 URL:            http://search.cpan.org/dist/Sys-Load/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 getload() returns 3 elements: representing load averages over the last
24 1, 5 and 15 minutes.  uptime() returns the system uptime in seconds.
25
26 %description -l pl.UTF-8
27 getload() zwraca 3 wartości, reprezentujące średnie obciążenie systemu
28 w ciągu ostatnich 1, 5 i 15 minut. uptime() zwraca uptime systemu w
29 sekundach.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make} \
38         CC="%{__cc}" \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Change* README
55 %{perl_vendorarch}/Sys/*.pm
56 %dir %{perl_vendorarch}/auto/Sys/Load
57 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Load/*.so
58 %{_mandir}/man3/*
This page took 0.065687 seconds and 4 git commands to generate.