]> git.pld-linux.org Git - packages/perl-Sub-Install.git/blob - perl-Sub-Install.spec
- updated to 0.929
[packages/perl-Sub-Install.git] / perl-Sub-Install.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define pdir    Sub
6 %define pnam    Install
7 Summary:        Sub::Install - install subroutines into packages easily
8 Summary(pl.UTF-8):      Sub::Install - łatwe instalowanie podprocedur do pakietów
9 Name:           perl-Sub-Install
10 Version:        0.929
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/Sub/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  81baf186c62c71f0935c3ccf1c5964c8
17 URL:            https://metacpan.org/dist/Sub-Install
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.78
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.96
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module makes it easy to install subroutines into packages without
30 the unslightly mess of no strict or typeglobs lying about where just
31 anyone can see them.
32
33 %description -l pl.UTF-8
34 Ten moduł ułatwia instalowanie podprocedur do pakietów bez niemałego
35 bałaganu no strict lub typeglobów umieszczonych wszędzie, gdzie każdy
36 może je zobaczyć.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Sub/Install.pm
61 %{_mandir}/man3/Sub::Install.3pm*
This page took 0.124722 seconds and 4 git commands to generate.