]> git.pld-linux.org Git - packages/perl-Sub-Exporter.git/commitdiff
- initial, 0.974, rel 1, builds here
authorMaciej Pijanka <agaran@pld-linux.org>
Sun, 27 May 2007 00:28:36 +0000 (00:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-Sub-Exporter.spec -> 1.1

perl-Sub-Exporter.spec [new file with mode: 0644]

diff --git a/perl-Sub-Exporter.spec b/perl-Sub-Exporter.spec
new file mode 100644 (file)
index 0000000..226a0a0
--- /dev/null
@@ -0,0 +1,74 @@
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    Sub
+%define        pnam    Exporter
+Summary:       Sub::Exporter - a sophisticated exporter for custom-built routines
+#Summary(pl):
+Name:          perl-Sub-Exporter
+Version:       0.974
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 916be83adf51eb8a0412f98e72605c88
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl(Data::OptList) >= 0.1
+BuildRequires: perl(Params::Util) >= 0.14
+BuildRequires: perl(Sub::Install) >= 0.92
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+ACHTUNG! If you're not familiar with Exporter or exporting, read
+Sub::Exporter::Tutorial first!
+
+The biggest benefit of Sub::Exporter over existing exporters
+(including the ubiquitous Exporter.pm) is its ability to build new
+coderefs for export, rather than to simply export code identical to
+that found in the exporting package.
+
+If your module's consumers get a routine that works like this:
+
+use Data::Analyze qw(analyze); my $value = analyze($data, $tolerance,
+$passes);
+
+and they constantly pass only one or two different set of values for
+the non-$data arguments, your code can benefit from Sub::Exporter. By
+writing a simple generator, you can let them do this, instead:
+
+
+
+# %description -l pl # TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorlib}/Sub/*.pm
+#%%{perl_vendorlib}/Sub/Exporter
+%{_mandir}/man3/*
This page took 0.113876 seconds and 4 git commands to generate.