]> git.pld-linux.org Git - packages/perl-Struct-Dumb.git/blob - perl-Struct-Dumb.spec
- don't load perl macros manually
[packages/perl-Struct-Dumb.git] / perl-Struct-Dumb.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Struct
6 %define pnam    Dumb
7 Summary:        Struct::Dumb - make simple lightweight record-like structures
8 Name:           perl-Struct-Dumb
9 Version:        0.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        https://cpan.metacpan.org/authors/id/P/PE/PEVANS/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  bb9ea100dc6f9ecd1c345381930dda08
16 URL:            http://search.cpan.org/dist/Struct-Dumb/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Struct::Dumb creates record-like structure types, similar to the
26 struct keyword in C, C++ or C#, or Record in Pascal. An invocation of
27 this module will create a construction function which returns new
28 object references with the given field values. These references all
29 respond to lvalue methods that access or modify the values stored.
30
31 It's specifically and intentionally not meant to be an object class.
32 You cannot subclass it. You cannot provide additional methods. You
33 cannot apply roles or mixins or metaclasses or traits or antlers or
34 whatever else is in fashion this week.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Struct/Dumb.pm
59 %{_mandir}/man3/Struct::Dumb.3pm*
This page took 0.131734 seconds and 4 git commands to generate.