]> git.pld-linux.org Git - packages/perl-String-CRC32.git/blob - perl-String-CRC32.spec
perl 5.38.0 rebuild
[packages/perl-String-CRC32.git] / perl-String-CRC32.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    String
6 %define         pnam    CRC32
7 Summary:        String::CRC32 - Perl interface to CRC32 generation
8 Summary(pl.UTF-8):      String::CRC32 - perlowy interfejs do generowania CRC32
9 Name:           perl-String-CRC32
10 Version:        1.7
11 Release:        6
12 License:        Public Domain
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/String/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  795a7c23fae9d24e485d4de08a58ef03
16 URL:            http://search.cpan.org/dist/String-CRC32/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 String::CRC32 module calculates CRC of 32 bit lenghts.
23
24 %description -l pl.UTF-8
25 Moduł String::CRC32 oblicza CRC długości 32 bitów.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33 %{__make} \
34         CC="%{__cc}" \
35         OPTIMIZE="%{rpmcflags}"
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README.md
51 %{perl_vendorarch}/String/CRC32.pm
52 %dir %{perl_vendorarch}/auto/String/CRC32
53 %attr(755,root,root) %{perl_vendorarch}/auto/String/CRC32/CRC32.so
54 %{_mandir}/man3/*
This page took 0.160985 seconds and 4 git commands to generate.